Application Failure After .NET Agent Installation
How to resolve an issue when an application fails to start after a .NET Core or .NET Framework Agent installation.
Summary
- Category: Agent operation
- Environment: IIS
- Severity/Impact: Critical
- Status: Known issue
- Impacted versions: All
Symptoms
After an installation of the Agent, applications, which were working previously, fail to start.
Cause
The Agent conflicts with other .NET profilers, such as APM tools, concurrently running on the same machine.
Resolution
- Identify the profiler(s) that cause the issue by disabling each profiler and checking if the application is working normally with the Agent.
- If a problematic profiler doesn't support chaining, it can't be used concurrently with the Agent.
- Configure the Agent to enable profiler chaining. For instructions, see Monitor applications concurrently with other .NET profilers.
If the issue persists, contact Support for available workarounds.