.NET Agent Disconnects from Server
How to resolve an issue when a .NET Core or .NET Framework Agent running on IIS disconnects from the Seeker server.
Summary
- Category: Agent connectivity
- Environment: IIS
- Severity/Impact: Critical
- Status: Known issue
- Impacted versions: All
Symptoms
A previously connected Agent does not appear as connected any more.
Cause
.NET Framework applications hosted in IIS go to sleep after a period of inactivity defined by the Idle Time-out application pool setting.
Resolution
Browse the application to activate it and load the Agent. After that, the Agent should appear as connected.